OperationSTART - Donation form not working – Incident details

Donation form not working

Resolved
Degraded performance
Started over 1 year agoLasted about 21 hours

Affected

OperationSTART Platform

Degraded performance from 11:01 PM to 8:25 PM

Updates
  • Resolved
    Resolved

    This issue has been resolved.

  • Investigating
    Investigating

    We are currently investigating an issue with our donation form on our website not working. If you are trying to make a donation, please contact us via email at development@operationstart.org. We hope to resolve this issue soon.

    UPDATE: You can make a donation using this form.